A React interface for Ampache player.

package.json 2.9KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293
  1. {
  2. "name": "ampache",
  3. "version": "1.0.0",
  4. "description": "A web client for Ampache, relying on Ampache API.",
  5. "author": "Phyks (Lucas Verney)",
  6. "license": "MIT",
  7. "homepage": "https://github.com/Phyks/ampache_react",
  8. "repository": "git+https://github.com/Phyks/ampache_react.git",
  9. "scripts": {
  10. "clean": "rimraf .cache && rimraf public/",
  11. "build:dev": "webpack --progress",
  12. "build:prod": "NODE_ENV=production webpack --progress",
  13. "watch:dev": "webpack --progress --watch",
  14. "watch:prod": "NODE_ENV=production webpack --progress --watch",
  15. "extractTranslations": "babel-node scripts/extractTranslations.js",
  16. "lint:scss": "stylelint './app/**/*.scss' --syntax scss",
  17. "lint:js": "eslint './app/**/*.js' './app/**/*.jsx'",
  18. "test": "npm run lint:scss && npm run lint:js"
  19. },
  20. "dependencies": {
  21. "autoprefixer": "^6.4.0",
  22. "babel-polyfill": "^6.9.1",
  23. "babel-preset-es2015": "^6.9.0",
  24. "bootstrap-loader": "^1.1.0",
  25. "bootstrap-sass": "^3.3.7",
  26. "eslint": "^3.2.2",
  27. "font-awesome": "^4.6.3",
  28. "fuse.js": "^2.4.1",
  29. "howler": "^2.0.0",
  30. "html5shiv": "^3.7.3",
  31. "humps": "^1.1.0",
  32. "imagesloaded": "^4.1.0",
  33. "immutable": "^3.8.1",
  34. "intl": "^1.2.4",
  35. "isomorphic-fetch": "^2.2.1",
  36. "isotope-layout": "^3.0.1",
  37. "jquery": "^3.1.0",
  38. "js-cookie": "^2.1.2",
  39. "jssha": "^2.1.0",
  40. "normalizr": "^2.2.1",
  41. "react": "^15.3.0",
  42. "react-addons-shallow-compare": "^15.3.0",
  43. "react-css-modules": "^3.7.9",
  44. "react-dom": "^15.3.0",
  45. "react-fontawesome": "^1.1.0",
  46. "react-intl": "^2.1.3",
  47. "react-redux": "^4.4.5",
  48. "react-router": "^2.6.1",
  49. "react-router-redux": "^4.0.5",
  50. "react-router-scroll": "^0.2.1",
  51. "redux": "^3.5.2",
  52. "redux-thunk": "^2.1.0",
  53. "stylelint": "^7.1.0",
  54. "x2js": "git+https://github.com/abdmob/x2js.git"
  55. },
  56. "devDependencies": {
  57. "autoprefixer": "^6.3.7",
  58. "babel-cli": "^6.11.4",
  59. "babel-core": "^6.10.4",
  60. "babel-loader": "^6.2.4",
  61. "babel-preset-react": "^6.11.1",
  62. "copy-webpack-plugin": "^3.0.1",
  63. "css-loader": "^0.23.1",
  64. "doiuse": "^2.4.1",
  65. "eslint": "^3.2.0",
  66. "eslint-loader": "^1.5.0",
  67. "eslint-plugin-react": "^5.2.2",
  68. "eventsource-polyfill": "^0.9.6",
  69. "extract-text-webpack-plugin": "^1.0.1",
  70. "file-loader": "^0.9.0",
  71. "font-awesome-webpack": "0.0.4",
  72. "glob": "^7.0.5",
  73. "less": "^2.7.1",
  74. "node-sass": "^3.8.0",
  75. "postcss": "^5.1.1",
  76. "postcss-loader": "^0.9.1",
  77. "postcss-reporter": "^1.4.1",
  78. "react-a11y": "^0.3.3",
  79. "redbox-react": "^1.2.10",
  80. "redux-logger": "^2.6.1",
  81. "resolve-url-loader": "^1.6.0",
  82. "rimraf": "^2.5.4",
  83. "sass-loader": "^4.0.0",
  84. "sass-resources-loader": "^1.0.2",
  85. "style-loader": "^0.13.1",
  86. "stylelint": "^7.0.3",
  87. "stylelint-config-standard": "^11.0.0",
  88. "url-loader": "^0.5.7",
  89. "webpack": "^1.13.1",
  90. "webpack-dev-server": "^1.14.1",
  91. "webpack-hot-middleware": "^2.12.2"
  92. }
  93. }